Jump to content

AIS vill inte fungera i OpenCPN


ebonita

Recommended Posts

Posted (edited)

Jag har en dator i salongen på min båt som jag haft kopplad med NMEA183 från en DigitalYacht AIT2000 AIS-transponder och sedan genom serial/USB interface till 2 st virtuella com-portar i datorn, en som är klockad på 38400 baud/s och en på 4800 baud/s. Det hela har fungerat utmärkt i många år med en Asrock i5  dator.

 

Men nu har jag bytt till Asus Vivo Mini i5 dator med ungefär samma prestanda men som har fördelen att den är lite mindre så den kan få plats bakom dataskärmen/salongs-TVn.

bild.png.f8cd2483c3752acbe3cf2e7e21da037f.png 

Tyvärr så vill inte AIS-funktionen fungera med den nya datorn.

I datorn är det ett program som heter ProAIS2 som användes för att konfigurera AIT2000 AIS transpondern, och i det programmet så ser allt bra ut. Konfigureringen fungerar och Diagnostiskt test visar att allt ser bra ut i AIS-transpondern. Det finns ett fönster med dataströmmen och det rinner på som tusan utan nämnvärt med felmeddelanden.

 

 

bild.png.3d27e3f877c73c0b48715bef2792a471.png 

 

 

Man kan kalla fram en AIS Target list och det blir  - som man kan vänta sig i mina hemmavatten - massor med synliga AIS-båtar.

 

bild.png.e3875f87fec4fd99eb9980c222c264b3.png

Men sen så kommer problemet för när man stänger ProAIS2 programmet och öppnar OpenCPN och riggar de aktuella Com-portarna med rätt baudrates och allt, så ser OpenCPN knappast några AIS-mål alls. Det blir en /mycket/ kort lista med synliga targets, och möjligen någon mycket enstaka gul eller i bästa fall grön AIS-båt på skärmen. Och detta som sagt i ett område där det veterligt ständigt finns många båtar med aktiv AIS-transponder.

bild.png.3696f5ebd824476139b00eb86dda9c38.png

Som synes så blir det några fåtaliga targets men alldeles för få och som sagt knappast några AIS-båtar på skärmen.

Bilderna ovan är tagna vid samma tidpunkt så antennen är det inget fel på.

Har lagt dagar av jobb på detta utan framgång.

Så jag skulle vara mycket tacksam om någon skulle kunna ge en hjälpande hand eller tips hur jag kan angripa detta...

 

 

 

 

bild.png

bild.png

Edited by ebonita
Link to post

Tack för svar!

 

Jag har idag tagit in den gamla datorn, en Asrock 4200 i5 med 12 Gb RAM till båten och kopplat till samma usb kablage från AIS-transpondern som jag provat till Asus Vivo Mini i5 med 8 Gb RAM. Datorerna ser på pappret ganska likvärdiga ut.

 

Jag fixade Com-portarna med samma baud-rate och samma enhetsbeteckning så att OpenCPN skulle känna igen portarna utan omställning.

 

Och si, det visade sig då att OpenCPN genast hittade och visade AIS-targets när jag anslöt till Asrock-datorn. Plenty!

 

Skall prova med Asus Vivo Mini i morgon igen. Jag tycker att denna applikation inte borde vara speciellt krävande för datorn, men finns det någon speciell egenskap i datorn som kan vara kritisk? Eller uttryckt på annat sätt kan jag göra något åt Asus Vivo Mini så att den klarar detta?

 

 

 

 

Link to post
Posted (edited)

Efter många timmars experimenterande har jag funnit ut att problemen har med SeaTalk att göra.

För om jag startar dator med opencpn utan att seatalk instrumenten får ström så fungerar det hela alldeles utmärkt även med Asus Vivo Mini datorn. Hade igår 55 targets i AIS-listan i opencpn innan jag slog till SeaTalk.

 

Men om jag sedan slår på SeaTalk så krymper listan till 10-20 mål, och många av dom (speciellt fritidsbåtar) anges som okända och blir gula i kartan. T ex i egen hamn där det veterligt finns ett halvdussin båtar med AIS transponder så ser jag kanske en /eller ingen/.

 

Så någonstans i Seatalk systemet har det uppkommit en störsändare.

 

Hur hittar men den?

Kan det kanske botas med ferriter?

 

Det har fungerat med nuvarande instrument och ledningsnät tidigare bortsett från att jag bytt dator och flyttat den närmare bildskärmen /=längre USB-kabel men kortare HDMI-kabel/

Edited by ebonita
Link to post
ebonita skrev for 3 timer siden:

Så någonstans i Seatalk systemet har det uppkommit en störsändare.

 

Hur hittar men den?

Kan det kanske botas med ferriter?

 

I følge Raymarine skal det hjelpe.

image.png.86818fe5a779b02dee93ccb794a164a3.png

 

image.png.dbe548a945f963b31efc8fa83fe26a22.png

Mulig den nye data`n støyer  eller feil på de nye kabler, eller for nærme bilde skjermen.??? 

Edited by Roger jo
Link to post

Tack Roger,

 

Det hela fungerar som sagt /allt annat oändrat/ om man slår av SeaTalk, så det känns mindre sannolikt /men givetvis inte uteslutet/ att felet sitter i dator/skärm.

 

Jag har beställt en påse ferriter från kinamannen med snabbleverans så dom skall hängas på plats enligt Din skiss så snart jag får dom.

 

SeaTalk är väl pulståg med låga frekvenser så om jag förstår det rätt så är det ingen är risk att man dämpar ut SeaTalk signaler med feritter?

 

jag ser att ni bidar avtagande vindar i Helsingör.

Men det finns ju lä att söka bara Ni kommer runt 'hjörnet'...

 

bild.png.93e840707c419ac423f3b22662aa163f.png

 

God tur vidare söderut!

 

:flag_sw:

Link to post

Create an account or sign in to comment

For Norwegians: Hvis du leser dette så er engelsk forumspråk aktivt, du kan endre dette til norsk med "System Language" knappen nederst på alle sider

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...