Jump to content

Billig DIY LifePO4 batteri.


Dreuf

Recommended Posts

Dreuf skrev 56 minutter siden:

@SamH 

Nå husker jeg ikke hvilke celler du har, men du har jo litt erfaring med praktisk bruk.

Hvor lavt slipper du cellene dine, hvilken ubalanse aksepterer du og hvor ofte må du rebalansere pakken?


 

Jeg har Winston celler, 8x400Ah 2p4s. Første halvdelen av pakka har gått i snaue 2 år, siste 400Ah kom til tidligere i høst.

Dynamoladingen er satt opp til å favorisere LFP, Multiplusen min favoriserer AGM. 
Jeg har i tillegg til LFP 3 stk Optima Bluetop og 1 stk Redtop.
Den ene Bluetopen er buffer på ladebussen for å håndtere plutselige frakoblinger og tid på landstrøm, de 2 siste er i paralell fremme for vinsj og thruster. Redtopen til start.


Jeg bor i båten i lange perioder hele året igjennom, mye i hjemhavn med landstrøm og da er LFP lagret på 13.15V, ellers på svai og da er de i bruk.


Dynamoen 240A v/MC614 lader til 14.6, og faller via 13.8 til 13.4 float. Tailstrømmen er 15-20A. Jeg pleier å ta LFP offline om jeg skal ha mer motortid enn det tar å fylle opp LFP. Ingen vits å kline fler ioner på ferdiglada celler. 


Landstrømmen v/Multiplus lader med høyere spenning, 15.6/13.9 + Victrons vedlikeholdsprogram, men som sagt er ikke LFP online da. Jeg kan legge de online manuellt og lade de, men det er i særskilte tilfeller. I praksis lader jeg LFP med dynamo, og klatter litt oppå det med sol og vind. Solcellene via Smartsolar MPPT er satt til AGM-verdier også, det samme er vindmøllen.
 

BMS(Rec Active) har aktiv balansering 2.5A, cut-off er satt 3.0/3.6, 0.1 hysterese. Balanseringsinslag hadde jeg satt enda høyere enn jeg husket 3.48V, cut-off 3.55.

I uthavn starter jeg gjerne opp og lader når LFP-SOC er rundt 25%'ish, men det varierer litt med hva jeg har tenkt resten av dagen, om jeg skal videre, lage mat på induksjon osv.
Jeg bryr meg fint lite om celleavvik under 95-100%, i det området begynner jeg å bli litt urolig rundt .005V. 
De første 4 cellene har vært ute to ggr for rebalansering på 2 år, den første gangen fordi balanseringen starta ved for lav spenning, og balanserte under lagring, den siste gangen da de 4 nye cellene ble satt inn for å matche de. 

Jeg tror egentlig ikke det er nødvendig med årlig regelmessig toppbalansering hos meg, ihvertfall ikke om jeg dropper å kødde til ting, lar BMS balansere der den skal, og absolutt ikke lenger enn den må. 

Jeg tror nok at både bruksmønster, hvilke celler, kringutrustning, lademuligheter osv i stor grad spiller inn på hva som er "riktige settinger", mao er det ikke en common fasit her.
Det beste rådet jeg ville gitt meg selv da jeg startet, ville vært å starte med sikre verdier, godt innafor maksverdier i noen retning, logga alt, tatt notater, og mens jeg fortsatte å logge og ta notater, forandret en ting av gangen etterhvert for å optimalisere. 

Link to post

@Okkaby: Samme her 😂 Sender deg en PM.

 

@Dreuf eller andre: Hvor lik må hvilespenningen egentlig være før en parallellkopler?.. Vi har tenkt at det raskeste er å lage 3 stk 4S pakker (sorterer cellene men de er så like at det nesten er hipp som happ - en av de blipper ned på 3.5V, de andre på 3.6V ish). Så balanseres 4S cellene med balancerkort - evt lader vi evt 4S cellene til lik spenning med en 12V lader mens balancerkortet jobber. Burde bli veldig likt, godt mulig de er like nok ved bare balansering. Men jeg har problemer med å bestemme meg for Max avvik før parallellkopling.. Ser AC impedans er oppgitt til 0.12 +/- 0.05 mOhm men klarer ikke å bestemme meg for om det første tallet er Ohm eller mOhm 😝 Det høres mest sannsynlig ut med Ohm, gjør det ikke?

 

Red: Ut fra dette er det nok mOhm... Jeg burde sikkert slutte å regne på det for disse strømmene ble så ekkelt store 😁 Spørs om jeg har nok desimaler på Hantek skopet mitt...

Edited by Fantino
Link to post

Jeg lader til rundt 3.45-3.5 hver celle, seriekobler gjerne for fortere å nå dit. (0-30V/10A strømforsyning) 

Når alle cellene er rundt deromkring paralellkobler jeg samtlige og lader til 3.6V, lar de stå sammenkobla noen timer uten lading, lader igjen til 3.6 og gjentar det et par ganger til. den første oppladingen i parallell kan ta mange dager om summen av cellekapasitet er høy. Jeg brukte nesten en uke sist gang(3200Ah).
Jeg lar de stå sammenkobla helt frem til jeg seriekobler dem. jeg har sikkert hatt .05 i forskjell før paralellkobling uten nevneverdige issues. 

Og det er mOhm, milliOhm. Det er derfor de tar og leverer strøm så fort ;)

Link to post

Det hørtes veldig greit ut @SamH! Da er target 0.05V avvik Max 😁 Må bare sjekke at lader stopper på passe spenning. Hvis ikke kopler vi opp bms og lar den kutte tror jeg. Greit å teste den også.

Link to post
Fantino skrev for 1 time siden:

Det hørtes veldig greit ut @SamH! Da er target 0.05V avvik Max 😁 Må bare sjekke at lader stopper på passe spenning. Hvis ikke kopler vi opp bms og lar den kutte tror jeg. Greit å teste den også.

Fikk jo testet min Heyo(Daly++) BMS nå. Stoppet nøyaktig på 3.55. Sto å fulgte med når den stoppet.

 

Så den fungere sikkert bra.

 

Men er jo litt moro å være forsøkskanin på dette. Om et år, så ligger det nok en bombesikker bruksanvisning for bygging av LiFePo her inne. Hvor mye det så har kostet os får vi bare le av over noen kalde pils😂🤣

Edited by Okkaby
Link to post
Okkaby skrev 27 minutter siden:

Stoppet nøyaktig på 3.55


Du burde også ved første og beste anledning sjekke at spenningsverdien fra BMS faktisk stemmer.  Det kan fort være avvik der mot hva som er riktig verdi. Noen du kjenner har kanskje en Fluke eller et labmeter som du kan verifisere med.

Link to post
SamH skrev 13 minutter siden:


Du burde også ved første og beste anledning sjekke at spenningsverdien fra BMS faktisk stemmer.  Det kan fort være avvik der mot hva som er riktig verdi. Noen du kjenner har kanskje en Fluke eller et labmeter som du kan verifisere med.

Har fluke multimeter sjøl en plass i kjelleren.

Så skal sjekke om det viser det samme ja.

 

Å Lamforsyning ligger bak i bilen nå. Kjøpt hos han Kjellen😁 

Link to post

11 celler målt til 3.26V her og den siste på 3.25V. Pinnebolter med Nylock og skiver i hus. Så da tenker vi å kople opp 3P4S med bms og 5A balancerkort og lade opp/balansere i en go. Rederen må bare få kassen helt ferdig først slik at vi får nøyaktig avstand på cellene for boring av bus bars.

69D7AA42-2841-45A9-8C67-2AEAD4543F4A.jpeg

Link to post

Husk å deaktivere bms sin balansering. Den kan visstnok lage krøll. 

Fikk mine balansekort i dag også. 

Stopper dere på ett nivå og tar resten i parallell? 

 

Jeg har demontert mitt batteri igjen for å kjøre en ny topp balanse på Samh sin måte. Er litt utålmodig så er usikker på om jeg har fått gjort det skikkelig første gang. Jeg ventet bare til jeg nærmer meg 0A og koblet det om til 4S.

Link to post

Ser ikke behovet for å kople i parallell hvis vi lader opp fra 3.25/6V til 3.55-ish og lar balancerkortet gjøre seg ferdig ved den høye spenningen og deretter deaktiverer det? Balancerkortet skal jo kunne flytte ladning med strøm i størrelsesorden det en lablader kan gi så burde virke?

Link to post

Var skeptisk til 35 mA balanseringsstrøm (BMS spec) på en 816 Ah pakke så vi handlet disse aktive balancerkortene som skal være bedre tilpasset jobben. Tanken er å la det henge tilkoplet men deaktivert for enkelt å kunne utføre vedlikeholdsbalansering når det måtte bli nødvendig. Men mener også de greit burde kunne brukes for toppbalansering ifm bygging av batteriet.

 

NOK 151.84  10% Off | Whole Group Balancer 3S 4S 5A Active Balancer Capacitor Active Equalizer Lifepo4 Lithium Lipo RV1-8 copper nose Wire connector
https://a.aliexpress.com/_mLksBel

Link to post

I teorien er disse kortene en Robin Hood. Henter strøm fra den høyeste cellen og gir til den laveste. Problemet er at den balanserer med mindre og mindre strøm desto mer like cellene blir..og det kommer til å ta evigheter. Leste på skjema til dem og de balanserer med 5A ved 0.1V forskjell og er nede på 1A ved 0.01V forskjell. 

 

Jeg tror beste måte er å lade dem som 4S pakker til første celle treffer 3.55V.

Deretter koble hele gjengen i parallell og lade dem til 3.6-3.65V. La dem stå noen dager for så å gjenta landingen. 

Iflg den videoen jeg har linket til over med Will Prowse så kan man balansere cellene bare ved å koble dem i parallell uten lader men da kan det gå noen mnd før de er skikkelig i balanse. 

 

Så sant man ikke har en heftig strømforsyning da. Da kan man kjøre dem i parallell med en gang og dure på. 

 

Link to post

Du trenger en relativt høy strøm for å toppbalansere, 2-3 A gjerne. Det vil også si at du må ha en relativt høy spenning. En balansekort, i den grad det er brukbart til noe som helst, dealer med celle til celle spenning, og den er fort bitteliten når strømmen som flyter er millilav. 
Skulle en ha en balansesak med egen powersupply som kan levere spenning utover høyeste celle og med strømkapasitet dertil står du fremdeles igjen med hvorfor i all verden du vil ha det der når alt den da gjør er å lade i paralell, du tilfører bare helt unødige og uoversiktlige feilkilder.

På et nivå hvor kjenner seg litt frem og kanskje er usikker på hva som er riktig og galt, ta det pent, gjør det oversiktlig. KISS .. 
Det går mye fortere å lade de initiellt i serie til rundt 3.45 eller what have you, og så sett de i paralell og lad til toppbalanseringsnivået. Det nivået er høyere enn normal ladetopp, det tar tid, men alle cellene er like, det skal mer lading til for å runde kneet, så du har mer tid til å fange det opp. Som Okkaby erfarte over, den kommer fort den vertikale biten av spenningskurven.. 
Winston-cellene har forøvrig hatt initiell lading/toppbalanserings anbefalinger begynnende på 4V i 2007, ned til 3.8 noen år senere og er nå 3.65V. 

Link to post

Hmm. Er uansett fristet til å teste hva det balancerkortet er i stand til. Det kan jo ikke sammenlignes med de interne resistorene? 1A ved 0.01V forskjell var egentlig mer enn jeg hadde trodd og er jo utrolig mye mer enn 35 mA.. Kan vi gjøre så mye galt ved å kople opp hele sulamitten inkl BMS og la sakene stå og godgjøre seg til vi ser hvor like eller ulike cellespenningene blir? Om det er fiasko så får vi plukke de og ta jobben med labladeren min på 3A og hvis det blir suksess så har vi en utrolig enkel måte å utføre ny toppbalansering på uten mekking, ved behov?

Link to post

1A er vel hva kortet greier. Desto nærmere cellene er med hverandre så vil det gå saktere og saktere. 

Ved ubalanse så ødelegger man ikke noe. Bms passer på at cellene ikke går for lavt eller høyt. Men man kan oppleve av bms kutter ved feks 13.8V. Da vil man aldri få ladet til F eks 14.2V. Man mister også strøm til det som er tilkoblet (plotter, autopilot etc) når BMS kutter og motor lader for fullt. 

Tilsvarende i bunn. Bms kan kutte på 12V i stede for 11V om man har stilt inn dette. 

 

Finnes også en lader. icharger x6 tror jeg den heter. Den lader hele pakken til første celle treffer F.eks 3.55V da kutter den lading av pakken og lader hver enkelt celle videre via balanse kablene. 

Link to post

Var denne saken som gjorde at vi gikk for balansekort:

 

https://liionbms.com/php/wp_balance_current.php

 

Spesielt frasen:

  • A balance current of 10 mA will not be able to balance a 1000 Ah pack within the lifetime of its owner

 😂

 

Oppfatter at grafen i artikkelen angir tid for balansering i pakke der en celle er flat og en er full.

 

Men jeg har også sett Will Prowse og han er klar og tydelig.. Det blir nok testing av balancerkort i første omgang da vi ikke har tilgang til lab supply før om en ukes tid. Og den gir uansett bare 3A så det vil ta sin tid det også. Samt at jeg har planer om å kjøre config via PC for å få satt alle parametre korrekt (Ref diskusjonen rundt batteri referansespenning bla).

Link to post

Demonterte hele sulamitten nu i kveld.

Kobla da på labforsyning på 5a.

Stilte inn denne til 3.65V å 5A

Når jeg kobler denne på første celle, så startet den ved 1.5A å går da stille å rolig nedover. 

Celle har spenning på ca 3.5 fra før. Er den cellen som slo ut bms så lading stoppa.

Så lure på om dette er rett som den oppfører seg.

Har lagret innstillingene i minnet på forsyning. 

IMG_20210122_211609.jpg

IMG_20210122_212021.jpg

IMG_20210122_213208.jpg

Link to post

Når den viser 0A da er den fulladet. 

Da gjør du det samme med de neste cellene. 

Så kobler du alle i parallell og lar dem stå ett par dager også setter du på strømforsyning igjen med 3.65.

Når du da ser 0A igjen så skrur da av strømforsyning og venter til neste dag. Så gjør du det samme igjen. 

Da skal de være bra balansert. 

(korriger meg om jeg tar feil @SamH

Link to post
Dreuf skrev 9 minutter siden:

Når den viser 0A da er den fulladet. 

Da gjør du det samme med de neste cellene. 

Så kobler du alle i parallell og lar dem stå ett par dager også setter du på strømforsyning igjen med 3.65.

Når du da ser 0A igjen så skrur da av strømforsyning og venter til neste dag. Så gjør du det samme igjen. 

Da skal de være bra balansert. 

(korriger meg om jeg tar feil @SamH

Får se om jeg rekker dette. Er snart tid for en tur i havet for å fylle litt på kontoen igjen. Går jo litt ut om dagen hehe

Link to post

Hvilke parameter teker du på @Fantino ?

 

Første celle er full her. nummer 2 står å er nu nede under 0.2A så ikke lenge til den er toppet heller.

 

Men skal jeg kjøre de i parallell så må jeg ute å finne noe som kan brukes til busbar, siden jeg kun har 3 stk.

Så må finne 3 til. Har Biltema noe som kan brukes der kanskje?

Link to post

Hvor kraftig kabel må jeg bruke om jeg bruker kabel mellom cellene til å topp lade de i parallel ?

Holder det med noe 6 kvadrat? Har jo masse kabelsko, å sikkert noe 6 kvadrat liggende. Så fort å lage noen lasker.

Link to post

Når alle er ganske like i spenning så går det minimalt med strøm og ledningene blir korte så 6mm går helt fint. 

Kan sende deg 3 ekstra busbars på mandag så har du. 

Link to post

@Fantino har 2stk BMSer får ikke forandret på noen av dem.

Har ikke prøvd å koble til usb siden jeg er ganske sikker på at SOC er ut fra spenning uansett. Og da har det liten betydning. Blir lekkert med de busbarene! 

Link to post

Create an account or sign in to comment

For Norwegians: Hvis du leser dette så er engelsk forumspråk aktivt, du kan endre dette til norsk med "System Language" knappen nederst på alle sider

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...